Your server is running PHP version 5.0.4 but WordPress 3.8.1 requires at least 5.2.4.